Follow

System Requirements for PLS Classes

PLS Classes System Requirements

The following technical requirements apply:

Preferred Operating Systems:

  • Windows XP
  • Windows Vista
  • Mac OS X

Preferred Browsers:

For an optimal experience use

  • Internet Explorer 7 (PC)
  • Mozilla Firefox 2 (PC or Mac).

Browser Support

To upgrade or install a new browser on your computer, click on the browser icon below.

  • '+' = listed version number and greater versions
  • NA = Not Available
   ie7.gif  firefox.gif  safari.gif Google-Chrome-Mac-Build-Available-for-Download-2.jpg 
 Windows  7+  2.0+  3.0+  2.0+
 Mac OS X  NA  1.5+  2.0+  NA
 Linux  NA  1.5+  NA  NA

Browser Plug-ins

To download the latest version of a plug-in, click on the icon or link below.

 flashmx.gif  Flash Player 8+
 pdf.gif  Adobe Acrobat Reader (PDF)
 java.gif  Java Runtime Library
 powerpoint.gif  Microsoft PowerPoint Viewer
 word.gif  Microsoft Word Viewer
 excel.gif  Microsoft Excel Viewer
 windowsmedia.gif  Windows Media Player
 quicktime.gif  QuickTime Player
 realplayer.gif  Real Player
 express.gif  Express Viewer (MrSID)
 smartboard.gif  SMART Board (SMART Notebook Viewer)


Comments

Powered by Zendesk